about summary refs log tree commit diff
path: root/nix/games.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/games.nix')
-rw-r--r--nix/games.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/nix/games.nix b/nix/games.nix
new file mode 100644
index 0000000..ec0e2d8
--- /dev/null
+++ b/nix/games.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, ... }:
+
+{
+  nixpkgs.config.allowUnfree = true;
+
+  environment.systemPackages = with pkgs; [
+    _20kly hedgewars globulation2 scorched3d teeworlds # strategy
+    astromenace chromium-bsu # scrolling
+    azimuth cdogs-sdl taisei # shmup
+    bastet moon-buggy n2048 # text
+    # blackshades redeclipse warsow xonotic-glx # fps
+    blobwars openclonk sienna superTux # platformer
+    bonzomatic # edu
+    extremetuxracer gl117 gltron superTuxKart # vehicle
+    flare freedroidrpg hyperrogue # slash
+    frozen-bubble gnujump gtetrinet pinball xbill # coffeebreak
+    neverball orthorobot trackballs # puzzle
+    (steam.override {
+      nativeOnly = true;
+      extraPkgs = pkgs: [ SDL2_net ];
+    }).run gnome.gtk # launcher
+  ];
+}