about summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-12-19 23:35:21 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-12-19 23:35:21 +0700
commitb3fc2bb0c2a84f8ddba609b7e145121eebb9ae7c (patch)
tree4b0abb405a84d33fce2190ae53c012f275fdf39a /pyproject.toml
downloadformbox-b3fc2bb0c2a84f8ddba609b7e145121eebb9ae7c.tar.gz
Snapshot working draft
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..9256938
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,22 @@
+[build-system]
+requires = [ "flit_core >=3.2,<4" ]
+build-backend = "flit_core.buildapi"
+
+[project]
+name = "formbox"
+version = "0.0.1"
+description = "Format mbox as HTML/XML"
+readme = "README.md"
+requires-python = ">=3.7"
+license = { file = "COPYING" }
+authors = [ { name = "Nguyễn Gia Phong", email = "mcsinyx@disroot.org" } ]
+maintainers = [ { name = "Nguyễn Gia Phong", email = "mcsinyx@disroot.org" } ]
+keywords = [ "email", "format", "html", "mbox", "template", "xml" ]
+classifiers = [
+    "Development Status :: 5 - Production/Stable",
+    "License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)",
+    "Operating System :: OS Independent",
+    "Programming Language :: Python",
+    "Topic :: Utilities" ]
+dependencies = [ "bleach", "markdown" ]
+urls = { Git = "https://git.sr.ht/~cnx/formbox" }