summary refs log tree commit diff
path: root/.dir-locals.el
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-01 23:11:17 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-01 23:21:01 +0100
commita20787706c246a9451b69db075a30ee91d28538b (patch)
tree5fb67cad6b5f65d4aa4be73966d5747c276f4ba2 /.dir-locals.el
parent537630c5a743251024b6bbd8b4eecf8811439cc6 (diff)
downloadguix-a20787706c246a9451b69db075a30ee91d28538b.tar.gz
guix package: Allow removal of a specific package output.
Fixes <http://bugs.gnu.org/15756>.

* guix/profiles.scm (<manifest-pattern>): New record type.
  (remove-manifest-entry): Remove.
  (entry-predicate, manifest-matching-entries): New procedures.
  (manifest-remove): Accept a list of <manifest-pattern>.
  (manifest-installed?): Replace 'name' parameter by 'pattern', a
  <manifest-pattern>.
* guix/scripts/package.scm (options->removable): Return a list of
  <manifest-pattern>.
  (guix-package)[process-action]: Use 'manifest-matching-entries' to
  compute the list of packages to remove.
* tests/profiles.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to '.dir-locals.el')
-rw-r--r--.dir-locals.el2
1 files changed, 2 insertions, 0 deletions
diff --git a/.dir-locals.el b/.dir-locals.el
index dc1a3d724d..240fae1c12 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -14,6 +14,8 @@
    (eval . (put 'substitute* 'scheme-indent-function 1))
    (eval . (put 'with-directory-excursion 'scheme-indent-function 1))
    (eval . (put 'package 'scheme-indent-function 0))
+   (eval . (put 'manifest-entry 'scheme-indent-function 0))
+   (eval . (put 'manifest-pattern 'scheme-indent-function 0))
    (eval . (put 'substitute-keyword-arguments 'scheme-indent-function 1))
    (eval . (put 'with-error-handling 'scheme-indent-function 0))
    (eval . (put 'with-mutex 'scheme-indent-function 1))