summary refs log tree commit diff
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-07-25 16:30:22 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-07-28 21:39:01 +0900
commit3d07888fc6628526478074294e618e71f18fbf91 (patch)
tree057744020eec530cd5d20f60b6835f38861e5b3d
parenta2e561f5eaab7d0000fe1bb7a29ea5e9914a2caa (diff)
downloadguix-ibus-table.tar.gz
gnu: Add ibus-table-others ibus-table
* gnu/packages/ibus.scm (ibus-table-others): New variable.
-rw-r--r--gnu/packages/ibus.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index a905ad7856..aa98a1a06f 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -941,6 +941,50 @@ hanja dictionary and small hangul character classification.")
       "ibus-table is a framework for table based input methods using IBus.")
     (license lgpl2.1+)))
 
+(define-public ibus-table-others
+  (package
+    (name "ibus-table-others")
+    (version "1.3.16")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://github.com/moebiuscurve/ibus-table-others/releases/"
+               "download/" version "/ibus-table-others-" version ".tar.gz"))
+        (sha256
+          (base32 "0vllwrjlgcvdjhs7nrg45hfvnivnfhrc05r6rhw8m0c41layl9jg"))))
+    (build-system gnu-build-system)
+    (arguments
+      (list #:phases
+            #~(modify-phases %standard-phases
+                (add-before 'build 'pre-build
+                  (lambda _
+                    (setenv "HOME" (getcwd)))))))  ; db written in $HOME
+    (native-inputs (list pkg-config python))
+    (inputs (list ibus ibus-table))
+    (home-page "https://github.com/moebiuscurve/ibus-table-others")
+    (synopsis "Various table-based input methods for IBus")
+    (description
+      "ibus-table-others provides the following input methods on IBus-Table on IBus framework:
+@itemize
+@item CNS11643
+@item Compose
+@item Emoji
+@item IPA-X-SAMPA
+@item LaTex
+@item Mathwriter
+@item Mongol bichig
+@item RussianTraditional
+@item Telex
+@item Thai
+@item Translit
+@item Ua-Translit
+@item Viqr
+@item VNI
+@item Yawerty
+@end itemize")
+    (license gpl3)))
+
 (define-public ibus-speech-to-text
   (package
     (name "ibus-speech-to-text")