summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-06 23:18:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-18 11:36:41 +0200
commit69e87c8d44bd8e30bd4be3b4df61caaed62d0a9a (patch)
tree0a42a3910f5c23849d09ce53ef443b320b42fcc9
parent3a3752400d7a70a295a27b66f29457aeeaa2cf27 (diff)
downloadguix-python-team.tar.gz
gnu: python-pygments: Update to 2.15.1. python-team
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 973216c5ed..f4f4cad427 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5955,18 +5955,23 @@ text styles of documentation.")
 (define-public python-pygments
   (package
     (name "python-pygments")
-    (version "2.12.0")
+    (version "2.15.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Pygments" version))
        (sha256
         (base32
-         "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
-    (build-system python-build-system)
+         "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+    (build-system pyproject-build-system)
     (arguments
-     ;; FIXME: Tests require sphinx, which depends on this.
-     '(#:tests? #f))
+     (list
+      #:test-flags
+      ;; Some tests require sphinx, which depends on this, so we only run
+      ;; basic tests.
+      '(list "--ignore-glob=tests/*/*")))
+    (native-inputs
+     (list python-pytest))
     (home-page "https://pygments.org/")
     (synopsis "Syntax highlighting")
     (description