summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-13 14:04:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-14 10:59:05 +0200
commit7966084069fb01223f86effdb77d29d4dc35ce4e (patch)
treeef5d369e9f1be863979b1894ff658fafd4eeea29
parentdac195c8f1494e2703449498ca0b2c58c1e4b105 (diff)
downloadguix-wip-aarch64-bootstrap.tar.gz
draft: gcc-core-mesboot1: adjust for aarch64-linux wip-aarch64-bootstrap
(%current-system) evaluated too early
use correct dynamic-linker
parameterize architecture in path
-rw-r--r--gnu/packages/commencement.scm54
1 files changed, 29 insertions, 25 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e6c5dfd47c..5c0a8233ec 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1443,29 +1443,29 @@ ac_cv_c_float_format='IEEE (little-endian)'
   ;; stricly needed, but very helpful for development because it builds
   ;; relatively fast.  If this configures and builds then gcc-mesboot1 also
   ;; builds.
-  (let ((triplet (match (%current-system)
-                   ((or "armhf-linux" "aarch64-linux")
-                    "arm-unknown-linux-gnu")
-                   ((or "i686-linux" "x86_64-linux")
-                    "i686-unknown-linux-gnu"))))
-    (package
-      (inherit gcc-mesboot0)
-      (name "gcc-core-mesboot1")
-      (version "4.6.4")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "mirror://gnu/gcc/gcc-"
-                                    version "/gcc-core-" version ".tar.gz"))
-                (sha256
-                 (base32
-                  "173kdb188qg79pcz073cj9967rs2vzanyjdjyxy9v0xb0p5sad75"))))
-      (supported-systems '("armhf-linux" "aarch64-linux"
-                           "i686-linux" "x86_64-linux"))
-      (inputs `(("gmp-source" ,gmp-boot)
-                ("mpfr-source" ,mpfr-boot)
-                ("mpc-source" ,mpc-boot)))
-      (native-inputs (%boot-mesboot1-inputs))
-      (arguments
+  (package
+    (inherit gcc-mesboot0)
+    (name "gcc-core-mesboot1")
+    (version "4.6.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gcc/gcc-"
+                                  version "/gcc-core-" version ".tar.gz"))
+              (sha256
+               (base32
+                "173kdb188qg79pcz073cj9967rs2vzanyjdjyxy9v0xb0p5sad75"))))
+    (supported-systems '("armhf-linux" "aarch64-linux"
+                         "i686-linux" "x86_64-linux"))
+    (inputs `(("gmp-source" ,gmp-boot)
+              ("mpfr-source" ,mpfr-boot)
+              ("mpc-source" ,mpc-boot)))
+    (native-inputs (%boot-mesboot1-inputs))
+    (arguments
+     (let ((triplet (match (%current-system)
+                           ((or "armhf-linux" "aarch64-linux")
+                            "arm-unknown-linux-gnu")
+                           ((or "i686-linux" "x86_64-linux")
+                            "i686-unknown-linux-gnu"))))
        (list #:implicit-inputs? #f
              #:guile %bootstrap-guile
              #:tests? #f
@@ -1479,7 +1479,11 @@ ac_cv_c_float_format='IEEE (little-endian)'
                                 "-B" libc "/lib "
                                 "-Wl,-dynamic-linker "
                                 "-Wl," libc
-                                #$(glibc-dynamic-linker "i686-linux"))))
+                                (match #$triplet
+                                       ("i686-unknown-linux-gnu"
+                                        #$(glibc-dynamic-linker "i686-linux"))
+                                       ("arm-unknown-linux-gnu"
+                                        #$(glibc-dynamic-linker "armhf-linux"))))))
                  (list (string-append "LDFLAGS=" ldflags)
                        (string-append "LDFLAGS_FOR_TARGET=" ldflags)))
              #:configure-flags
@@ -1561,7 +1565,7 @@ ac_cv_c_float_format='IEEE (little-endian)'
                             (kernel-headers (assoc-ref %build-inputs "kernel-headers")))
                        (setenv "CONFIG_SHELL" (string-append bash "/bin/sh"))
                        (setenv "C_INCLUDE_PATH" (string-append
-                                                 gcc "/lib/gcc-lib/i686-unknown-linux-gnu/2.95.3/include"
+                                                 gcc "/lib/gcc-lib/" #$triplet "/2.95.3/include"
                                                  ":" kernel-headers "/include"
                                                  ":" glibc "/include"
                                                  ":" (getcwd) "/mpfr/src"))