summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 15:50:58 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-29 15:50:58 +0200
commit0e8923831ba7253587f5e7fc9f9aa90a6f94446b (patch)
treed32ad48612024ad9d001ca995df4973411802c71
parent911e33ead1483ee802985453ef2c33e047113049 (diff)
downloadguix-wip-file-offset-bits-64.tar.gz
gnu: cyrus-sasl: Explicity declare the _FILE_OFFSET_BITS we want. wip-file-offset-bits-64
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[arguments]<#:phases>[ensure-file-offset-bits-64]:
Explicity declare the _FILE_OFFSET_BITS we want.
-rw-r--r--gnu/packages/cyrus-sasl.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 3e65a1faf6..2d7cc91cec 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -68,6 +68,11 @@
 
       #:phases
       (modify-phases %standard-phases
+        (add-before 'configure 'ensure-file-offset-bits-64
+          (lambda _
+            (setenv "CFLAGS" "-D_FILE_OFFSET_BITS=64")
+            (setenv "CXXFLAGS" "-D_FILE_OFFSET_BITS=64")
+            #t))
         (add-after 'unpack 'autogen
           (lambda _
             (invoke "autoreconf" "-vif"))))))