summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-04 19:38:36 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-04 19:38:36 +0200
commit4c11d9ef24c2e5ee529f49cdc62147c7dcfdc4d9 (patch)
tree501473f110f97b3596849424e41f2f7ecfd60db8
parentd1edfd01b898fac387c8cbbdd6fe9b33480f8b43 (diff)
downloadguix-wip-file-offset-bits-64-sledgehammer.tar.gz
gnu: pciutils: Explicity declare the _FILE_OFFSET_BITS we want. wip-file-offset-bits-64-sledgehammer
* gnu/packages/pciutils.scm (pciutils)[arguments]<#:phases>[configure]: Pass
CFLAGS.
-rw-r--r--gnu/packages/pciutils.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index c992988437..1e35e58a3f 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -87,7 +87,10 @@
 
                (("^IDSDIR=.*$")
                 ;; Installation directory of 'pci.ids.gz'.
-                "IDSDIR = $(SHAREDIR)/hwdata\n"))
+                "IDSDIR = $(SHAREDIR)/hwdata\n")
+               (("^OPT=")
+                "OPT?="))
+             (setenv "OPT" (getenv "CFLAGS"))
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)