summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 13:02:49 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 13:02:49 -0800
commit61b70fcf45b96a65e71d1377083d8709796f66c4 (patch)
tree5622ceee3a47fc702487239f446e95d68a939e7d
parent215d10f8058d9a7beffd3c852a4c1c0f2f3b6a26 (diff)
downloadguix-wip-mediagoblin.tar.gz
gnu: Add python-chardet. wip-mediagoblin
* gnu/packages/python.scm (python-chardet, python2-chardet): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0f95140391..3c95ad5b00 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8163,6 +8163,33 @@ ISO 8859, etc.).")
               (strip-python2-variant python-translitcodec)))
     (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
 
+(define-public python-chardet
+  (package
+    (name "python-chardet")
+    (version "2.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "chardet" version))
+       (sha256
+        (base32
+         "1ak87ikcw34fivcgiz2xvi938dmclh078az65l9x3rmgljrkhgp5"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/chardet/chardet")
+    (synopsis
+     "Universal encoding detector for Python 2 and 3")
+    (description
+     "Character encoding auto-detection in Python.  Effectively determines what
+character set to use for input with a high degree of accuracy.")
+    (license lgpl2.1+)
+    (properties `((python2-variant . ,(delay python2-chardet))))))
+
+(define-public python2-chardet
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-chardet)))
+    (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
 (define-public python-editor
   (package
   (name "python-editor")