summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-10 22:23:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-03-19 21:14:38 +0200
commitc271a6c7760663fce8589eca29f9067ba30af27d (patch)
tree5086d8ba08bbca0da0e46f43da5ffd705cea701a
parent3008a4f8fb240726055825b4732465d0a3aec60d (diff)
downloadguix-wip-perl6.tar.gz
gnu: Add perl6-json. wip-perl6
* gnu/packages/perl6.scm (perl6-json): New variable.
-rw-r--r--gnu/packages/perl6.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index f67533854f..f227786e8d 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -284,6 +284,29 @@ code.  Any grammar in the lexical scope of the use statement will automatically
 have profiling information collected when the grammar is used.")
       (license license:artistic2.0))))
 
+(define-public perl6-json
+  (package
+    (name "perl6-json")
+    (version "1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/moritz/json")
+               ;; The commit where 1.0 was "tagged"
+               (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
+    (build-system rakudo-build-system)
+    (arguments '(#:with-zef? #f))
+    (home-page "https://github.com/moritz/json")
+    (synopsis "A minimal JSON (de)serializer")
+    (description "This module is a simple Perl 6 module for serializing and
+deserializing JSON.")
+    (license license:artistic2.0)))
+
 (define-public perl6-json-class
   (package
     (name "perl6-json-class")