summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-04-11 01:14:10 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-04-11 01:14:10 -0700
commit263abc66793cb17023f57f02cba2bcab1d6684fb (patch)
treea13336070be19a40fa9602543e7a88cfe7b18215
parent46050437e85a02f92f3ac11c28c28ae6bc6e34da (diff)
parent98067662f645cab1c22a51d6b9ed6b3140ecaf9e (diff)
downloadguix-wip-pinebook-pro.tar.gz
Merge remote-tracking branch 'origin/master' into wip-pinebook-pro wip-pinebook-pro
-rw-r--r--doc/guix.texi2
-rw-r--r--gnu/packages/bootloaders.scm6
-rw-r--r--gnu/packages/lisp-xyz.scm36
3 files changed, 40 insertions, 4 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 218ff35ce9..bb86195a25 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -33529,7 +33529,7 @@ $(guix system vm config.scm) -nic user,model=virtio-net-pci,hostfwd=tcp::10022-:
 To connect to the VM you can run
 
 @example
-ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -p 10022
+ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -p 10022 localhost
 @end example
 
 The @command{-p} tells @command{ssh} the port you want to connect to.
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index c9a3d2c217..6093e0d9e6 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -478,15 +478,15 @@ tree binary files.  These are board description files used by Linux and BSD.")
 (define u-boot
   (package
     (name "u-boot")
-    (version "2021.01")
+    (version "2021.04")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "ftp://ftp.denx.de/pub/u-boot/"
+                    "https://ftp.denx.de/pub/u-boot/"
                     "u-boot-" version ".tar.bz2"))
               (sha256
                (base32
-                "0m04glv9kn3bhs62sn675w60wkrl4m3a4hnbnnw67s3l198y21xl"))))
+                "06p1vymf0dl6jc2xy5w7p42mpgppa46lmpm2ishmgsycnldqnhqd"))))
     (native-inputs
      `(("bc" ,bc)
        ("bison" ,bison)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0f6d0103d5..1d8e0b42bb 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -25,6 +25,7 @@
 ;;; Copyright © 2021 Matthew Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 André A. Gomes <andremegafone@gmail.com>
 ;;; Copyright © 2021 Cage <cage-dev@twistfold.it>
+;;; Copyright © 2021 Cameron Chaparro <cameron@cameronchaparro.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15789,3 +15790,38 @@ allows one to gradually make their programs safer.")
 
 (define-public cl-coalton
   (sbcl-package->cl-source-package sbcl-coalton))
+
+(define-public sbcl-clip
+  (let ((commit "7afa68702fbb99c47ed115ea0faccd97a29d9b2e")
+        (revision "1"))
+    (package
+      (name "sbcl-clip")
+      (version (git-version "0.7.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/shinmera/clip")
+               (commit commit)))
+         (file-name (git-file-name "clip" version))
+         (sha256
+          (base32 "13kkajkva2shm19fvn4yashsw18l6imv2rmy3hmpcky7g5ay7bv3"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("array-utils" ,sbcl-array-utils)
+         ("lquery" ,sbcl-lquery)))
+      (home-page "https://shinmera.github.io/clip/")
+      (synopsis "Common Lisp HTML templating engine")
+      (description
+       "Clip is an attempt at a templating library that allows you to write
+templates in a way that is both accessible to direct webdesign and
+flexible.  The main idea is to incorporate transformation commands into an HTML
+file through tags and attributes.  Clip is heavily dependant on Plump and
+lQuery.")
+      (license license:zlib))))
+
+(define-public ecl-clip
+  (sbcl-package->ecl-package sbcl-clip))
+
+(define-public cl-clip
+  (sbcl-package->cl-source-package sbcl-clip))