summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-10 08:42:02 +0100
committerChristopher Baines <mail@cbaines.net>2018-01-14 22:16:26 +0000
commit0076f5a98c6f88a1d1d1824592bb8886b02b1894 (patch)
treed8fd1ddb2e41b5a4b5b52e360017cecaaead2519
parent2c2ec3d04a36914390c7617bb9971fd840b40646 (diff)
downloadguix-0076f5a98c6f88a1d1d1824592bb8886b02b1894.tar.gz
gnu: Remove redundant wrapping from packages using ruby-build-system.
Now that the build system does wrapping automatically, it can be removed from
the packages that do it manually.

* gnu/packages/databases.scm (es-dump-restore)[arguments]: Remove #:phases.
* gnu/packages/ruby.scm (ruby-redcloth)[arguments]: Remove #:phases.
  (ruby-httpclient)[arguments]: Remove 'wrap-bin-httpclient from the modified
  phases.
-rw-r--r--gnu/packages/databases.scm13
-rw-r--r--gnu/packages/ruby.scm20
2 files changed, 3 insertions, 30 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7bcce44e7..70202beea4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -291,18 +291,7 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
          "020yk7f1hw48clmf5501z3xv9shsdchyymcv0y2cci2c1xvr1mim"))))
     (build-system ruby-build-system)
     (arguments
-     '(#:tests? #f ;; No testsuite.
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-bin-es_dump_restore
-           (lambda* (#:key outputs #:allow-other-keys)
-             (wrap-program (string-append (assoc-ref outputs "out")
-                                          "/bin/es_dump_restore")
-               `("GEM_PATH" ":" prefix (,(getenv "GEM_PATH")
-                                        ,(string-append
-                                          (assoc-ref outputs "out")
-                                          "/lib/ruby/vendor_ruby"))))
-             #t)))))
+     '(#:tests? #f)) ;; No testsuite.
     (propagated-inputs
      `(("ruby-httpclient" ,ruby-httpclient)
        ("ruby-multi-json" ,ruby-multi-json)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ab3c077036..ac852f54b8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2852,17 +2852,7 @@ alternative to Marshal for Object serialization. ")
          ;; existing gemspec.
          (replace 'build
           (lambda _
-            (zero? (system* "gem" "build" "redcloth.gemspec"))))
-         ;; Make sure that the "redcloth" executable finds required Ruby
-         ;; libraries.
-         (add-after 'install 'wrap-bin-redcloth
-          (lambda* (#:key outputs #:allow-other-keys)
-            (wrap-program (string-append (assoc-ref outputs "out")
-                                         "/bin/redcloth")
-              `("GEM_PATH" ":" prefix (,(string-append
-                                         (assoc-ref outputs "out")
-                                         "/lib/ruby/vendor_ruby"))))
-            #t)))))
+            (zero? (system* "gem" "build" "redcloth.gemspec")))))))
     (native-inputs
      `(("bundler" ,bundler)
        ("ruby-diff-lcs" ,ruby-diff-lcs)
@@ -3710,13 +3700,7 @@ It has built-in support for the legacy @code{cookies.txt} and
                   (system* "ruby"
                            "-Ilib"
                            "test/runner.rb"))
-                 #t)))
-         (add-after 'install 'wrap-bin-httpclient
-           (lambda* (#:key outputs #:allow-other-keys)
-             (wrap-program (string-append (assoc-ref outputs "out")
-                                          "/bin/httpclient")
-               `("GEM_PATH" ":" prefix (,(getenv "GEM_PATH"))))
-             #t)))))
+                 #t))))))
     (native-inputs
      `(("ruby-rack" ,ruby-rack)))
     (synopsis