summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-18 11:59:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-18 12:01:34 +0100
commit007f6d9885b81543b02489e503e51264677ed132 (patch)
treeaa29b875c9cdb85aac72bb9dbbb3a516ba32cc8b
parentf90018e56821397ae28fada1c4d823c3e0c8750e (diff)
downloadguix-007f6d9885b81543b02489e503e51264677ed132.tar.gz
gnu: Add r-ggjoy.
* gnu/packages/cran.scm (r-ggjoy): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e0e44067aa..e7c9c6588a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1751,3 +1751,25 @@ plotting.  a three dimensional point cloud.")
 distributions over time or space.  This package enables the creation of such
 plots in @code{ggplot2}.")
     (license license:gpl2)))
+
+(define-public r-ggjoy
+  (package
+    (name "r-ggjoy")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggjoy" version))
+       (sha256
+        (base32
+         "1s24zn7gmk52bvjjhanxby7rxbnc2yfl0nx5nv7x7z0zja8gg7nb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-ggridges" ,r-ggridges)))
+    (home-page "https://github.com/clauswilke/ggjoy")
+    (synopsis "Joyplots in ggplot2")
+    (description "Joyplots provide a convenient way of visualizing changes in
+distributions over time or space.  This package enables the creation of such
+plots in @code{ggplot2}.")
+    (license license:gpl2)))