summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-16 09:01:19 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-16 09:04:21 +0200
commit011862f5ff680db9abcdf918cff3a513712b64c2 (patch)
tree87e6aeb0301ef907fa39dfe01bfd6bf185c9eaeb
parent77480fb19212e7c323e2506c5bb3e1bfe21ead15 (diff)
downloadguix-011862f5ff680db9abcdf918cff3a513712b64c2.tar.gz
gnu: Add python-cwcwidth.
* gnu/packages/python-xyz.scm (python-cwcwidth): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8b3777f8f..9fdd133db5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26143,3 +26143,28 @@ supports x86_64 instructions up to AVX-512 and SHA.")
       (description "This package is a port of sgmllib that is no longer part
 of Python 3.")
       (license license:bsd-3))))
+
+(define-public python-cwcwidth
+  (package
+    (name "python-cwcwidth")
+    (version "0.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cwcwidth" version))
+       (sha256
+        (base32
+         "1azrphpkcyggg38xvkfb9dpc4xmmm90p02kf8dkqd4d6j5w96aj8"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-cython" ,python-cython)
+       ("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-toml" ,python-toml)
+       ("python-wheel" ,python-wheel)))
+    (home-page
+     "https://github.com/sebastinas/cwcwidth")
+    (synopsis "Python bindings for wc(s)width")
+    (description "This package provides bindings for wcwidth and wcswidth
+functions defined in POSIX.1-2001 and POSIX.1-2008.")
+    (license license:expat)))