summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-01 16:22:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:43 +0300
commit01530df91bc46ac4dfb226730ae29967319e8a96 (patch)
tree14e383ade8db1f9f6732040b8e5f0f4aa370f02e
parentd890f1a39443e2fef789bad111e3f87c5a24a94b (diff)
downloadguix-01530df91bc46ac4dfb226730ae29967319e8a96.tar.gz
gnu: Add rust-float-eq-derive-1.
* gnu/packages/crates-io.scm (rust-float-eq-derive-1): New variable.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cd3f397f95..c16112b519 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25057,6 +25057,28 @@ traits.")
         (base32
          "0036jb8ry4h83n319jb20b5yvyfyq8mx8dkxnyjm22nq8fl8yjhk"))))))
 
+(define-public rust-float-eq-derive-1
+  (package
+    (name "rust-float-eq-derive")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "float-eq-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0mkg635lmr0nwjlxz6f5k8g60hrd800i061hrlmpvhdkl96d74j2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://jtempest.github.io/float_eq-rs/")
+    (synopsis "Derive macro support for float_eq")
+    (description "This package provides the derive macro support for float_eq.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-float-ord-0.3
   (package
     (name "rust-float-ord")