summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:10:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:43 +0200
commit016746cec404d1a4e40d0165f18edbfe033e36b0 (patch)
treeb4195b73167b6cb3c4ead4f5ff86d51b8c7498ca
parentb90f9a8988c1156430aa2f40dfcfa70174c8e55d (diff)
downloadguix-016746cec404d1a4e40d0165f18edbfe033e36b0.tar.gz
gnu: Add texlive-ksp-thesis.
* gnu/packages/tex.scm (texlive-ksp-thesis): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c1349a2ff..7e85992f83 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18480,6 +18480,31 @@ KSFH (@emph{Katholische Stiftungsfachhochschule}) Munich.  BibTeX entries in
 @code{misc} formats are supported.")
     (license license:lppl1.3+)))
 
+(define-public texlive-ksp-thesis
+  (package
+    (name "texlive-ksp-thesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ksp-thesis/"
+                   "tex/latex/ksp-thesis/")
+             (base32
+              "03jklx2yym78b29y3s8fh91mfsn9p4w1cl7yisj3kyyawygzs6hp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ksp-thesis")
+    (synopsis
+     "LaTeX class for theses published with KIT Scientific Publishing")
+    (description
+     "This package provides a LaTeX class intended for authors who want to
+publish their thesis or other scientific work with @acronym{KSP, KIT
+Scientific Publishing}.  The class is based on the @code{scrbook} class of the
+KOMA-script bundle in combination with the ClassicThesis and ArsClassica
+packages.  It modifies some of the layout and style definitions of these
+packages in order to provide a document layout that should be compatible with
+the requirements by KSP.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-kvmap
   (package
     (name "texlive-kvmap")