summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-06-25 12:27:03 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:30 +0800
commit02910653ceb1068dced569087c948e7e665bc2d8 (patch)
tree0fc3b0fa1971612d921beb7cc6e736d81a09064f
parentd2419557d1fe6e7d4205f39453a7e16ca64763c5 (diff)
downloadguix-02910653ceb1068dced569087c948e7e665bc2d8.tar.gz
gnu: Add libkscreen-5.
* gnu/packages/kde-plasma.scm (libkscreen-5): New variable.
* gnu/packages/lxqt.scm (lxqt-config)[propagated-inputs]: Switch to it.

Change-Id: I7cce1a02251800496c731883f64fc17938dd8ceb
-rw-r--r--gnu/packages/kde-plasma.scm39
-rw-r--r--gnu/packages/lxqt.scm3
2 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 1f0a9c22ea..a2a0160692 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1189,6 +1189,45 @@ Workspaces which tries to be as magic and automatic as possible for users with
 basic needs and easy to configure for those who want special setups.")
     (license license:gpl2+)))
 
+;; use by lxqt-config
+(define-public libkscreen-5
+  (package
+    (inherit libkscreen)
+    (name "libkscreen")
+    (version "5.27.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/plasma/" version "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32 "1ary7qavz8vkzbvjx2mxv09h61hxa7i4f7rfgbykldbc83ripdc6"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (setenv "HOME" (getcwd))
+                     (setenv "QT_QPA_PLATFORM" "offscreen")
+                     (setenv "WAYLAND_DISPLAY" "libkscreen-test-wayland-backend-0")
+                     (invoke "ctest" "-E"
+                             (string-append "(kscreen-testedid"
+                                            "|kscreen-testqscreenbackend"
+                                            "|kscreen-testkwaylandbackend"
+                                            "|kscreen-testkwaylandconfig"
+                                            "|kscreen-testkwaylanddpms)"))))))))
+    (native-inputs
+     (list extra-cmake-modules
+           pkg-config
+           qttools-5
+           ;; For testing.
+           dbus))
+    (inputs
+     (list kconfig-5 kwayland-5 libxrandr plasma-wayland-protocols
+           qtbase-5 qtwayland-5 wayland qtx11extras))))
+
 (define-public libksysguard
   (package
     (name "libksysguard")
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 5c1dd67cc5..af4efe4494 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2020 Fakhri Sajadi <f.sajadi@pantherx.org>
 ;;; Copyright © 2020 André Batista <nandre@riseup.net>
 ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -371,7 +372,7 @@ the operating system LXQt is running on.")
     ;; XXX: This is a workaround so libkscreen can find the backends as we
     ;; dont have a way specify them. We may want to  patch like Nix does.
     (propagated-inputs
-     (list libkscreen))
+     (list libkscreen-5))
     (arguments
      '(#:tests? #f                      ; no tests
        #:phases