summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:19 +0200
commit02db014892a576f1a3f3ab6eda2fce9a1226472d (patch)
treef7a4a04748eea716f3882bb368b1f3ef88ae1536
parentb2e6117512b1cab6a0cbb070f31f1b1991c7cbd6 (diff)
downloadguix-02db014892a576f1a3f3ab6eda2fce9a1226472d.tar.gz
gnu: Add texlive-sparklines.
* gnu/packages/tex.scm (texlive-sparklines): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 43d72f0ff7..7100d28fd5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96179,6 +96179,28 @@ adjustment.")
 available from AtF Spark.")
     (license (list license:silofl1.1 license:lppl1.3+))))
 
+(define-public texlive-sparklines
+  (package
+    (name "texlive-sparklines")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sparklines/"
+                   "tex/latex/sparklines/")
+             (base32
+              "0p40s93s51bf67gf8mq5v888mm9nhabwd4gr8lyhaf5hhl2g8909")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sparklines")
+    (synopsis "Drawing sparklines: intense, simple, wordlike graphics")
+    (description
+     "Sparklines are intense, simple, wordlike graphics.  A sparkline can be added
+using the @code{sparkline} environment.  Also, you can add sparkling
+rectangles for the median and special sparkling dots in red or blue.  The
+package requires pdfLaTeX; sparklines cannot appear in a DVI file.  The
+sparklines package uses PGF.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar