summary refs log tree commit diff
diff options
context:
space:
mode:
authordan <i@dan.games>2023-09-25 01:14:00 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-26 11:30:52 -0400
commit031784f9f9ab0782abf646d3c764294516dbcd99 (patch)
treef81790f7b089e5d3963cf3904677ec2643a8e368
parentbdce0646ae342cf9e0e9bc74634dd27f67150752 (diff)
downloadguix-031784f9f9ab0782abf646d3c764294516dbcd99.tar.gz
gnu: Add tracy.
* gnu/packages/profiling.scm (tracy): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/profiling.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/profiling.scm b/gnu/packages/profiling.scm
index 23f989a85c..3615eb417c 100644
--- a/gnu/packages/profiling.scm
+++ b/gnu/packages/profiling.scm
@@ -30,6 +30,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)      ;for "which"
+  #:use-module (gnu packages bash)      ;for "which"
   #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages documentation)
@@ -463,3 +464,18 @@ high-performance computing (HPC) applications.")
      "A real time, nanosecond resolution, remote telemetry, hybrid frame and
 sampling profiler for games and other applications.")
     (license license:bsd-3)))
+
+(define-public tracy
+  (package;xb
+    (inherit tracy-wayland)
+    (name "tracy")
+    (arguments
+     (substitute-keyword-arguments (package-arguments tracy-wayland)
+       ((#:make-flags flags #~'())
+        #~(append #$flags
+                  ;; The LEGACY flag indicate we want to build tracy with glfw.
+                  (list "LEGACY=1")))))
+    (inputs (modify-inputs (package-inputs tracy-wayland)
+              (delete "libxkbcommon" "wayland")
+              (prepend glfw)))
+    (synopsis "Frame profiler (X11 version)")))