summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:15 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:52 -0500
commit03702173f1b4d0dc5578e3554c2501f381a87696 (patch)
treee7f7e5e261a424f7c197315a454d5558cc6a1758
parent3ef00f56090ad20e55eeab09ae82803211b07024 (diff)
downloadguix-03702173f1b4d0dc5578e3554c2501f381a87696.tar.gz
gnu: Add python-openid-cla.
* gnu/packages/python.scm (python-openid-cla, python2-openid-cla): New
variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 36e3df8735..d61dd6c95e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5392,6 +5392,27 @@ another XPath engine to find the matching elements in an XML or HTML document.")
 (define-public python2-cssselect
   (package-with-python2 python-cssselect))
 
+(define-public python-openid-cla
+  (package
+    (name "python-openid-cla")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-openid-cla" version))
+       (sha256
+        (base32
+         "102hy2qisvjxp5s0v9lvwqi4f2dk0dhns40vjgn008yxc7k0h3cr"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/puiterwijk/python-openid-cla/")
+    (synopsis "Implementation of the OpenID CLA extension for python-openid")
+    (description "@code{openid-cla} is an implementation of the OpenID
+contributor license agreement extension for python-openid.")
+    (license license:bsd-3)))
+
+(define-public python2-openid-cla
+  (package-with-python2 python-openid-cla))
+
 (define-public python-netifaces
   (package
     (name "python-netifaces")