summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 19:12:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:50 +0300
commit0508e30d8ab56d037d9cbffe13574d89b6ed6a8b (patch)
tree3bdb5b9dbafc4b737e732419447cf694af6dae08
parentc86c05e08e7e39a67f348e30d44d03bd6dc38a7b (diff)
downloadguix-0508e30d8ab56d037d9cbffe13574d89b6ed6a8b.tar.gz
gnu: Remove rust-arrow2-0.5.
* gnu/packages/crates-io.scm (rust-arrow2-0.5): Delete variable.
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 213e194979..3ea8e8aa94 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3746,49 +3746,6 @@ code of Apache Arrow spec.")
 a re-write of the official Arrow crate using transmute-free operations.")
     (license license:asl2.0)))
 
-(define-public rust-arrow2-0.5
-  (package
-    (inherit rust-arrow2-0.7)
-    (name "rust-arrow2")
-    (version "0.5.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "arrow2" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "042m859jfffnhi84qc919pkyanlr98wqqf67pcrylk4hhh0v84xx"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-ahash" ,rust-ahash-0.7)
-        ("rust-base64" ,rust-base64-0.13)
-        ("rust-chrono" ,rust-chrono-0.4)
-        ("rust-chrono-tz" ,rust-chrono-tz-0.5)
-        ("rust-comfy-table" ,rust-comfy-table-4)
-        ("rust-csv" ,rust-csv-1)
-        ("rust-flatbuffers" ,rust-flatbuffers-2)
-        ("rust-futures" ,rust-futures-0.3)
-        ("rust-hash-hasher" ,rust-hash-hasher-2)
-        ("rust-hex" ,rust-hex-0.4)
-        ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-itertools" ,rust-itertools-0.10)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-lexical-core" ,rust-lexical-core-0.8)
-        ("rust-lz4" ,rust-lz4-1)
-        ("rust-multiversion" ,rust-multiversion-0.6)
-        ("rust-num-traits" ,rust-num-traits-0.2)
-        ("rust-packed-simd-2" ,rust-packed-simd-2-0.3)
-        ("rust-parquet2" ,rust-parquet2-0.4)
-        ("rust-rand" ,rust-rand-0.8)
-        ("rust-regex" ,rust-regex-1)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-derive" ,rust-serde-derive-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-streaming-iterator" ,rust-streaming-iterator-0.1)
-        ("rust-strength-reduce" ,rust-strength-reduce-0.2)
-        ("rust-zstd" ,rust-zstd-0.9))))))
-
 (define-public rust-article-scraper-1
   (package
     (name "rust-article-scraper")