summary refs log tree commit diff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-05-29 14:14:15 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-05 12:11:05 +0200
commit051e5a049daba024231b04e264084fb62dd59181 (patch)
tree2cfd10a041d44234379452d1aef91f4c71eda901
parent3695a8d32ecbb7bf45b5adaa1f9b358467e22751 (diff)
downloadguix-051e5a049daba024231b04e264084fb62dd59181.tar.gz
gnu: Add minetest-sound-api-core.
* gnu/packages/minetest.scm (minetest-sound-api-core): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/minetest.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 2efd1468d2..e6af5fe8ad 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -213,6 +213,36 @@ as swords and tools made of different materials.  It also adds copper rails.")
     (license license:zlib)
     (properties `((upstream-name . "Calinou/moreores")))))
 
+(define-public minetest-sound-api-core
+  (package
+    (name "minetest-sound-api-core")
+    ;; No tags, no releases. The author intended to let users use it as a
+    ;; submodules for other projects.
+    ;; https://github.com/mt-mods/basic_materials/issues/4
+    (version "2022-02-27")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mt-mods/sound_api_core")
+             (commit "6956e49e775f325116f8e0c643899c089c691e1e")))
+       (sha256
+        (base32 "1ys6g2skhkksa4cx9agxhsibj5js8z4y2q1ngis9ddr38p756pcy"))
+       (file-name (git-file-name name version))
+       (snippet
+        '(begin
+           (call-with-output-file "mod.conf"
+             (lambda (port)
+               (format port "\
+name = sound_api_core")))))))
+    (build-system minetest-mod-build-system)
+    (propagated-inputs '())
+    (home-page "https://github.com/mt-mods/sound_api_core")
+    (synopsis "Core for game agnostic sounds")
+    (description
+     "This library can be used to get some specific sounds, whatever the game.")
+    (license license:expat)))
+
 (define-public minetest-basic-materials
   (package
     (name "minetest-basic-materials")