summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 08:40:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:23 +0200
commit0687343d01543642a273d9b0041e4f0d0b187174 (patch)
treebe6e5a08b28e672171a90ec5f22042d6e6261f13
parent809e704d94a1ba0e90ad1750716505c1657ad421 (diff)
downloadguix-0687343d01543642a273d9b0041e4f0d0b187174.tar.gz
gnu: texlive-underscore: Refresh package definition.
* gnu/packages/underscore (texlive-underscore): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9bba168074..c2aaaa045b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -736,16 +736,19 @@ documentation from TeX files.  It is part of the LaTeX base.")
 
 (define-public texlive-underscore
   (package
-    (inherit (simple-texlive-package
-              "texlive-underscore"
-              (list "/doc/latex/underscore/"
-                    "/tex/latex/underscore/")
-              (base32
-               "0slxsxc9azmv3gsm55jkhkv8a06wafankp55hhsdd6k4prp8szrb")
-              #:trivial? #t))
+    (name "texlive-underscore")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/underscore/" "tex/latex/underscore/")
+             (base32
+              "0slxsxc9azmv3gsm55jkhkv8a06wafankp55hhsdd6k4prp8szrb")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
     (home-page "https://www.ctan.org/pkg/underscore")
     (synopsis "Control the behaviour of @samp{_} in text")
-    (description "This package causes @code{\\_} in text mode (i.e.,
+    (description
+     "This package causes @code{\\_} in text mode (i.e.,
 @code{\\textunderscore}) to print an underscore so that hyphenation of words
 either side of it is not affected; a package option controls whether an actual
 hyphenation point appears after the underscore, or merely a break point.  The