summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:28 +0200
commit07369f131cf6a432502d7df45f643f38194a2520 (patch)
treeaf2915e874fa6d3bf2c3fa447ff94c6513b9120a
parent85d6b3d531614571922e2c0849485a2ae6341528 (diff)
downloadguix-07369f131cf6a432502d7df45f643f38194a2520.tar.gz
gnu: Add texlive-qsymbols.
* gnu/packages/tex.scm (texlive-qsymbols): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 06b5635a14..f1b06378f3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93380,6 +93380,28 @@ packages make extensive use of in their package documentation, providing
 illustrated examples that are automatically verified to work as expected.")
     (license license:lppl)))
 
+(define-public texlive-qsymbols
+  (package
+    (name "texlive-qsymbols")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/qsymbols/"
+                   "source/latex/qsymbols/"
+                   "tex/latex/qsymbols/")
+             (base32
+              "02hb4d193dqsm2190alr4mh49rdx7wyy51281amz8pnfnkhlqifc")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/qsymbols")
+    (synopsis "Maths symbol abbreviations")
+    (description
+     "This package provides macros for defining systematic mnemonic abbreviations,
+starting with @samp{`} for math symbols and @samp{\\\"} for arrows, using
+standard symbols as well as those from the @code{amsfonts} bundle and the
+@code{stmaryrd} package.")
+    (license license:gpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar