summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-27 19:01:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-27 19:33:53 +0100
commit081d8a34bf77bc8489655ee18fa60ae4a37e8f15 (patch)
treeb11987be38e62c9869093c7a43d0acf85406a442
parent93ae39dfcdde8019797baa032e58b8120e371ad2 (diff)
downloadguix-081d8a34bf77bc8489655ee18fa60ae4a37e8f15.tar.gz
gnu: gst-plugins-good, gst-plugins-ugly: Add missing common phases.
* gnu/packages/gstreamer.scm (gst-plugins-good, gst-plugins-ugly)
[arguments]: Run the %common-gstreamer-phases.
-rw-r--r--gnu/packages/gstreamer.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 5392f4ad38..256f298346 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -598,6 +598,7 @@ for the GStreamer multimedia library.")
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases
        (modify-phases %standard-phases
+         ,@%common-gstreamer-phases
          (add-after 'unpack 'fix-broken-test
            (lambda _
              ;; Fix test failure on 32-bit.  Remove for > 1.18.1.
@@ -802,6 +803,7 @@ par compared to the rest.")
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases
        (modify-phases %standard-phases
+         ,@%common-gstreamer-phases
          (add-before 'check 'pre-check
            (lambda _
              ;; Tests require a running X server.