summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-23 10:03:48 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-23 10:03:48 +0100
commit086f27cf8cb4198d15d7d65c8703d50b58ab3c03 (patch)
tree685210a57be0e5a8d25eba3b248211b4003988e9
parent2a0431e064f3508e6baaf6afe66a28b50ffd2651 (diff)
downloadguix-086f27cf8cb4198d15d7d65c8703d50b58ab3c03.tar.gz
gnu: Add soapyremote.
* gnu/packages/radio.scm (soapyremote): New variable.
-rw-r--r--gnu/packages/radio.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 15c068bd79..ad7982f256 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -40,6 +40,7 @@
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages astronomy)
   #:use-module (gnu packages audio)
+  #:use-module (gnu packages avahi)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
@@ -478,6 +479,33 @@ controls for certain tuners which may be paired with an audio device.")
 a single device wrapper.")
       (license license:boost1.0))))
 
+(define-public soapyremote
+  (let ((commit "f375555e7380acfd2517acde598e2e553e08df88")
+        (revision "1"))
+    (package
+      (name "soapyremote")
+      (version (git-version "0.5.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pothosware/SoapyRemote")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0whn87wck7agsk3af4lh7nyyjn0ncs3xdny4vsd94qbjikfl6x5z"))))
+      (build-system cmake-build-system)
+      (inputs
+       (list avahi soapysdr))
+      (arguments
+       '(#:tests? #f)) ; No test suite
+      (home-page "https://github.com/pothosware/SoapyRemote")
+      (synopsis "Remote support for Soapy SDR")
+      (description
+       "This is a SoapySDR module to use a supported device transparently over
+a local network link.")
+      (license license:boost1.0))))
+
 (define-public soapyrtlsdr
   (package
     (name "soapyrtlsdr")