summary refs log tree commit diff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:26 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:32:09 -0500
commit088af734098fdf30d5fcc6be614e30a8cb04751b (patch)
treead0205b7de0f8c2be6aafda3fcca51a3162534e1
parent22789276b53d6156ddb722c68615c22a54a35d27 (diff)
downloadguix-088af734098fdf30d5fcc6be614e30a8cb04751b.tar.gz
gnu: Add go-github-com-emersion-go-milter.
* gnu/packages/golang.scm (go-github-com-emersion-go-milter): New
  variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1a4d0cc681..eea2d2e10d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6767,6 +6767,30 @@ defined by RFC 5321.")
 format.")
     (license license:expat)))
 
+(define-public go-github-com-emersion-go-milter
+  (package
+    (name "go-github-com-emersion-go-milter")
+    (version "0.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/go-milter")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10vpry5gjz2bh9qchcx4p59zm7cc6cb6bfkii2n6vsn4svb950sa"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/emersion/go-milter"))
+    (propagated-inputs (list go-github-com-emersion-go-message))
+    (home-page "https://github.com/emersion/go-milter")
+    (synopsis "Milter mail filters in Go")
+    (description
+     "This package provides an interface for implementing milter mail
+filters for Go.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-fatih-color
   (package
     (name "go-github-com-fatih-color")