summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:14 +0200
commit0a5c4fb6c6f720cffdc879944e7739fb14760fad (patch)
tree767394107892026f29094075385398133033bb1e
parent13fcb322045c5c8e42312c39c2d5150d5e8ba209 (diff)
downloadguix-0a5c4fb6c6f720cffdc879944e7739fb14760fad.tar.gz
gnu: Add texlive-skeyval.
* gnu/packages/tex.scm (texlive-skeyval): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 20c7a440ee..8deae0708c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95870,6 +95870,27 @@ combinations of parameters and keys.  All the facilities of the @code{ltxkeys}
 and @code{skeyval} packages are available to the user of @code{skeycommand}.")
     (license license:lppl1.3+)))
 
+(define-public texlive-skeyval
+  (package
+    (name "texlive-skeyval")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/skeyval/" "tex/latex/skeyval/")
+             (base32
+              "09647p16f50wa9yz9jfypwckginvlv0897x4gb7m69pbvgnsdf4i")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/skeyval")
+    (synopsis
+     "Key-value parsing combining features of @code{xkeyval} and @code{pgfkeys}")
+    (description
+     "The package integrates the features of @code{xkeyval} and of @code{pgfkeys}
+by introducing a new type of handlers.  Style keys, links, changing key
+callbacks and values on the fly, and other features of @code{pgfkeys} are
+introduced in a new context.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar