summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-01-23 17:44:53 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-01-23 20:02:32 -0500
commit0af6ffdd8d81f86a232902a54f99d4cfcd369490 (patch)
tree6f888a23dd3f8e1a0baeabc50638f948f9916bca
parentf3a13a21e50fa3751fc39e5768ea6843bfc19df2 (diff)
downloadguix-0af6ffdd8d81f86a232902a54f99d4cfcd369490.tar.gz
gnu: qscintilla: Update to 2.10.2.
* gnu/packages/qt.scm (qscintilla, python-qscintilla, python-pyqt+qscintilla):
Update to 2.10.2.
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 70c76ee454..596006080a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1657,7 +1657,7 @@ contain over 620 classes.")
 (define-public qscintilla
   (package
     (name "qscintilla")
-    (version "2.10.1")
+    (version "2.10.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pyqt/QScintilla2/"
@@ -1665,7 +1665,7 @@ contain over 620 classes.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0r7s7ndblv3jc0xig1y4l64b6mfr879cdv3zwdndn27rj6fqmycp"))))
+                "1l2ylsv6s3wfhyx7qr5cxgkwwwhvbrpd2k7akgm9bvbyf4h1vcql"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -1685,7 +1685,7 @@ contain over 620 classes.")
                   (string-append out "/lib/qt$${QT_MAJOR_VERSION}"))
                  (("\\$\\$\\[QT_HOST_DATA\\]")
                  (string-append out "/lib/qt$${QT_MAJOR_VERSION}")))
-               (zero? (system* "qmake"))))))))
+               (invoke "qmake")))))))
     (native-inputs `(("qtbase" ,qtbase)))
     (home-page "http://www.riverbankcomputing.co.uk/software/qscintilla/intro")
     (synopsis "Qt port of the Scintilla C++ editor control")
@@ -1715,8 +1715,8 @@ indicators, code completion and call tips.")
          (replace 'configure
            (lambda* (#:key outputs configure-flags #:allow-other-keys)
              (chdir "Python")
-             (and (zero? (apply system* "python3" "configure.py"
-                                configure-flags))
+             (and (apply invoke "python3" "configure.py"
+                         configure-flags)
                   ;; Install to the right directory
                   (begin
                     (substitute* '("Makefile"