summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:49 +0200
commit0b0527a774f4a22de5ba7d42f63b36975c681b75 (patch)
tree97709093bbf7289578badf134c57b4384c230294
parent126da7110991e6ae05d12a868f1335f56fa59ef0 (diff)
downloadguix-0b0527a774f4a22de5ba7d42f63b36975c681b75.tar.gz
gnu: Add texlive-saveenv.
* gnu/packages/tex.scm (texlive-saveenv): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 48307e5d29..8df3c42226 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94478,6 +94478,25 @@ MakeIndex and pdfLaTeX.")
 catcodes.")
     (license license:lppl1.3c)))
 
+(define-public texlive-saveenv
+  (package
+    (name "texlive-saveenv")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/saveenv/" "tex/latex/saveenv/")
+             (base32
+              "0m3pmzmqpksymlqn71d5p98d10yg3nqz7a5pqcylpb4a8w0g63r7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-precattl))
+    (home-page "https://ctan.org/pkg/saveenv")
+    (synopsis "Save environment content verbatim")
+    (description
+     "This package provides tools to create your own verbatim environments, and
+works for all values of @code{\\endlinechar}.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar