summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-06-23 21:48:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-06-24 08:34:45 -0400
commit0dacf51553405da41a9df1d7a0ebbf1f401267ae (patch)
treeae867e49f9b98e9ebbf4f659d524025876549cd2
parenta8547a0febbc0a987f02424295699b3506ce8f21 (diff)
downloadguix-0dacf51553405da41a9df1d7a0ebbf1f401267ae.tar.gz
gnu: gauche: Remove trailing #t.
* gnu/packages/scheme.scm (gauche) [phases]: Remove trailing #t.

Change-Id: I47b4f2a7475a41e6431bba0c3d6bd21b9f584fc5
-rw-r--r--gnu/packages/scheme.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8bf72deb23..927e10bbfe 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1116,24 +1116,20 @@ The core is 12 builtin special forms and 33 builtin functions.")
                             "ext/tls/test.scm"
                             "lib/gauche/package/util.scm"
                             "libsrc/gauche/process.scm")
-               (("/bin/sh") (which "sh")))
-             #t))
+               (("/bin/sh") (which "sh")))))
          (add-after 'build 'build-doc
            (lambda _
              (with-directory-excursion "doc"
-               (invoke "make" "info"))
-             #t))
+               (invoke "make" "info"))))
          (add-before 'check 'patch-network-tests
            ;; Remove net checks.
            (lambda _
              (delete-file "test/net.scm")
-             (invoke "touch" "test/net.scm")
-             #t))
+             (invoke "touch" "test/net.scm")))
          (add-after 'install 'install-docs
            (lambda _
              (with-directory-excursion "doc"
-               (invoke "make" "install"))
-             #t)))))
+               (invoke "make" "install")))))))
     (synopsis "Scheme scripting engine")
     (description "Gauche is a R7RS Scheme scripting engine aiming at being a
 handy tool that helps programmers and system administrators to write small to