summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-07 00:35:34 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-07 00:35:34 +0200
commit0e4e4b1329bcf881620f230fda60b6b63d1f8356 (patch)
treecddd575d2ffa4e191304a2b3ec37500ac069da64
parent872c69d00e861f86fa4caaadbaa136f46c9db358 (diff)
downloadguix-0e4e4b1329bcf881620f230fda60b6b63d1f8356.tar.gz
gnu: gettext: Upgrade to 0.19.
* gnu/packages/gettext.scm (gnu-gettext): Upgrade to 0.19.
  [arguments] <phases>: Remove now unneeded 'link-expat' phase.  Patch
  lang-sh and msgfilter test scripts; patch msginit.c and project-id.
  Add #:make-flags.
-rw-r--r--gnu/packages/gettext.scm35
1 files changed, 20 insertions, 15 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index e5a2c6e479..c2159db1de 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -34,37 +34,42 @@
 (define-public gnu-gettext
   (package
     (name "gettext")
-    (version "0.18.3.2")
+    (version "0.19")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gettext/gettext-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1my5njl7mp663abpdn8qsm5i462wlhlnb5q50fmhgd0fsr9f996i"))))
+               "0z44pm0vh4rmj8jq6lww0qhw72r2dkqs31vnlnn851y69dvcgyd9"))
+             (patches (list (search-patch "gettext.patch")))))
     (build-system gnu-build-system)
     (inputs
      `(("expat" ,expat)))
     (arguments
      `(#:phases (alist-cons-before
-                 'configure 'link-expat
-                 (lambda _
-                   (substitute* "gettext-tools/configure"
-                     (("LIBEXPAT=\"-ldl\"") "LIBEXPAT=\"-ldl -lexpat\"")
-                     (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\"")))
-                (alist-cons-before
                  'check 'patch-tests
                  (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (which "sh")))
-                     (substitute* (find-files "gettext-tools/tests"
-                                              "^msgexec-[0-9]")
+                   (let* ((bash (which "sh")))
+                     (substitute*
+                         (find-files "gettext-tools/tests"
+                                     "^(lang-sh|msg(exec|filter)-[0-9])")
                        (("#![[:blank:]]/bin/sh")
                         (format #f "#!~a" bash)))
-                     (substitute* (find-files "gettext-tools/gnulib-tests"
-                                              "posix_spawn")
+
+                     (substitute* (cons "gettext-tools/src/msginit.c"
+                                        (find-files "gettext-tools/gnulib-tests"
+                                                    "posix_spawn"))
                        (("/bin/sh")
-                        bash))))
-                 %standard-phases))))
+                        bash))
+
+                     (substitute* "gettext-tools/src/project-id"
+                       (("/bin/pwd")
+                        "pwd"))))
+                 %standard-phases)
+
+       ;; When tests fail, we want to know the details.
+       #:make-flags '("VERBOSE=yes")))
     (home-page "http://www.gnu.org/software/gettext/")
     (synopsis "Tools and documentation for translation")
     (description