summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-11-21 10:23:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:46 +0100
commit0e60dda0ae235044e692626d7b4532f63c591c5a (patch)
tree17529ea4474c14eb99eb01b1a9ec283dc74dbad3
parent10c87ecf777af2c2aebe0775fba75237c20df279 (diff)
downloadguix-0e60dda0ae235044e692626d7b4532f63c591c5a.tar.gz
gnu: Add r-scuttle.
* gnu/packages/bioconductor.scm (r-scuttle): New variable.
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7f188a4115..3572b605c6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8837,6 +8837,40 @@ factors for each cell, along with the usual metadata for genes and
 libraries.")
     (license license:gpl3)))
 
+(define-public r-scuttle
+  (package
+    (name "r-scuttle")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "scuttle" version))
+       (sha256
+        (base32
+         "1k8q3wzq6f6j6wkjp9fy9j214rv98kyvcxnpavk6blqgaxjqwdr6"))))
+    (properties `((upstream-name . "scuttle")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-beachmat" ,r-beachmat)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-biocparallel" ,r-biocparallel)
+       ("r-delayedarray" ,r-delayedarray)
+       ("r-delayedmatrixstats" ,r-delayedmatrixstats)
+       ("r-matrix" ,r-matrix)
+       ("r-rcpp" ,r-rcpp)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-singlecellexperiment" ,r-singlecellexperiment)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/scuttle")
+    (synopsis "Single-cell RNA-Seq analysis utilities")
+    (description
+     "This package provides basic utility functions for performing single-cell
+analyses, focusing on simple normalization, quality control and data
+transformations.  It also provides some helper functions to assist development
+of other packages.")
+    (license license:gpl3)))
+
 (define-public r-scater
   (package
     (name "r-scater")