summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 22:26:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 22:26:26 +0100
commit0f2a77e14f8080a9f158f75d2634664565e81173 (patch)
tree38140a3b51ae65a66a35ff628d54da8a5550cee6
parent9bc0f45df5d6aed217020b1183dca54989844fb0 (diff)
downloadguix-0f2a77e14f8080a9f158f75d2634664565e81173.tar.gz
gnu: Add libnftnl/fixed.
* gnu/packages/linux.scm (libnftnl/fixed): New variable.
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a8c48f1bb7..b41c2d5b4f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2656,7 +2656,7 @@ external rate conversion.")
        ("bison" ,bison)))
     (inputs
      `(("libmnl" ,libmnl)
-       ("libnftnl" ,libnftnl)))
+       ("libnftnl" ,libnftnl/fixed)))
     (arguments
      '(#:tests? #f       ; no test suite
        #:configure-flags ; add $libdir to the RUNPATH of executables
@@ -7074,6 +7074,24 @@ libnftnl has been previously known as libnftables.  This library is currently
 used by nftables.")
     (license license:gpl2+)))
 
+;; This is used in iptables, which contributes to rust.  We're pinning this
+;; variant to avoid accidental rebuilds of rust.
+(define-public libnftnl/fixed
+  (package (inherit libnftnl)
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://netfilter.org/libnftnl/"
+                           "libnftnl-" version ".tar.bz2"))
+       (sha256
+        (base32 "1xblq1cbcxhr6qmjpy98i1qdza148idgz99vbhjc7s4vzvfizc4h"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libmnl" ,libmnl)))))
+
 (define-public nftables
   (package
     (name "nftables")