summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-20 00:24:17 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-20 00:24:17 +0200
commit0f323dad0e7e2bf259003a956140d4d0cb4fc0e5 (patch)
treed66c8da917a1b1efd6d3b36c257afd071ccdf2a8
parent3dfd7cef0dc7b868354cbbc9ca30d837a3a8b30d (diff)
downloadguix-0f323dad0e7e2bf259003a956140d4d0cb4fc0e5.tar.gz
gnu: Add lzip.
* gnu/packages/compression.scm (lzip): New variable.
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 8196d695b3..9528cf3199 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -200,3 +200,24 @@ compression ratio.
 LZO is written in ANSI C.  Both the source code and the compressed data
 format are designed to be portable across platforms.")
     (license license:gpl2+)))
+
+(define-public lzip
+  (package
+    (name "lzip")
+    (version "1.14")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://savannah/lzip/lzip-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "1rybhk2pxpfh2789ck9mrkdv3bpx7b7miwndlshb5vb02m9crxbz"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.nongnu.org/lzip/lzip.html")
+    (synopsis "Lossless data compressor based on the LZMA algorithm")
+    (description
+     "Lzip is a lossless data compressor with a user interface similar to the
+one of gzip or bzip2.  Lzip decompresses almost as fast as gzip and compresses
+more than bzip2, which makes it well suited for software distribution and data
+archiving.  Lzip is a clean implementation of the LZMA algorithm.")
+    (license license:gpl3+)))