summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:37:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:38 +0200
commit10011abc44b6714911bd3d3bc5b675c55ae583da (patch)
tree319846d0fc64d69e7c7b66bd2a311c1178613df8
parent28f384e85c93e16e8edaf4d8e0d96a287ae978f0 (diff)
downloadguix-10011abc44b6714911bd3d3bc5b675c55ae583da.tar.gz
gnu: simple-texlive-package: Remove it.
* gnu/packages/tex.scm (simple-texlive-package): Remove variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d7bd82e6e..6ce5e372a4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -103,33 +103,6 @@
   #:use-module (ice-9 match)
   #:use-module ((srfi srfi-1) #:hide (zip)))
 
-(define* (simple-texlive-package name locations hash
-                                 #:key trivial?)
-  "Return a template for a simple TeX Live package with the given NAME,
-downloading from a list of LOCATIONS in the TeX Live repository, and expecting
-the provided output HASH.  The TRIVIAL? keyword is not used."
-  (set! locations
-        ;; Some locations may be manually inserted, so be tolerant with
-        ;; leading slashes.  Ignore them consistently.
-        (map (lambda (location)
-               (if (string-prefix? "/" location)
-                   (string-drop location 1)
-                   location))
-             locations))
-  (define with-documentation?
-    (any (lambda (l) (string-prefix? "doc/" l))
-         locations))
-  (package
-    (name name)
-    (version (number->string %texlive-revision))
-    (source (texlive-origin name version locations hash))
-    (outputs (if with-documentation? '("out" "doc") '("out")))
-    (build-system texlive-build-system)
-    (home-page #f)
-    (synopsis #f)
-    (description #f)
-    (license #f)))
-
 (define hyph-utf8-scripts
   (origin
     (method svn-fetch)