summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-07 10:48:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-07 11:29:59 +0200
commit10abb0519033ca2218ade2f73ced312f1665306d (patch)
tree0c896e1c32fbee11b7caa3f998020c26067f684d
parentb43c3a745c4b192437ba833a2ab30647853e0d26 (diff)
downloadguix-10abb0519033ca2218ade2f73ced312f1665306d.tar.gz
gnu: libx264: Fix building on riscv64-linux.
* gnu/packages/video.scm (libx264)[inputs]: Add config.
[arguments]: Adjust configure-flags to always build PIC code. Add custom
phase to replace config.guess, config.sub scripts.
-rw-r--r--gnu/packages/video.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index de9fb42904..b3e6e5ef7b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -904,6 +904,8 @@ shared library and encoder and decoder command-line executables.")
       (build-system gnu-build-system)
       (native-inputs
        (list pkg-config nasm))
+      (inputs
+       (list config))
       ;; TODO: Add gpac input
       (arguments
        `(#:tests? #f                    ;no check target
@@ -914,6 +916,7 @@ shared library and encoder and decoder command-line executables.")
                              ;; program depends on ffmpeg and ffmpeg depends on
                              ;; libx264).
                              "--disable-cli"
+                             "--enable-pic"
 
                              ;; On MIPS, we must pass "--disable-asm" or else
                              ;; configure fails after printing: "You specified a
@@ -924,7 +927,17 @@ shared library and encoder and decoder command-line executables.")
                                                    (or (%current-target-system)
                                                        (%current-system)))
                                    '("--disable-asm")
-                                   '()))))
+                                   '()))
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'update-config-scripts
+             (lambda* (#:key native-inputs inputs #:allow-other-keys)
+               (for-each (lambda (file)
+                               (install-file
+                                 (search-input-file
+                                   (or native-inputs inputs)
+                                   (string-append "/bin/" file)) "."))
+                         '("config.guess" "config.sub")))))))
       (home-page "https://www.videolan.org/developers/x264.html")
       (synopsis "H.264 video coding library")
       (description "libx264 is an advanced encoding library for creating