summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-28 11:53:51 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-28 15:45:48 +0100
commit10b507b234b627cb076f58c8e21a8b4088593b3e (patch)
tree4ed0a03eafba0c472046b7630af12d893fdb70c9
parent40864d79fc310618601636b06e6ac197c1ac178a (diff)
downloadguix-10b507b234b627cb076f58c8e21a8b4088593b3e.tar.gz
gnu: Remove now unused 'package-for-guile-2.2' procedure.
* gnu/packages/guile.scm (package-for-guile-2.2): Remove.
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 09f6676960..869fec97bd 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -388,14 +388,9 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
                                     (string-length "guile-")))
         name)))
 
-(define package-for-guile-2.2
-  ;; A procedure that rewrites the dependency tree of the given package to use
-  ;; GUILE-2.2 instead of GUILE-2.0.
-  (package-input-rewriting `((,guile-2.0 . ,guile-2.2))
-                           (guile-variant-package-name "guile2.2")))
-
 (define package-for-guile-2.0
-  ;; Likewise, but the other way around.  :-)
+  ;; A procedure that rewrites the dependency tree of the given package to use
+  ;; GUILE-2.0 instead of GUILE-2.2.
   (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
                            (guile-variant-package-name "guile2.0")))