summary refs log tree commit diff
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 03:36:51 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-29 15:31:18 +0200
commit111110038d3ff78a354f13130994081db82ee0d4 (patch)
tree28323cdbcc0d3caada62fac7e25f1fb2792553af
parenta9bcc6474667d6699500f03d69f9c8212a50d711 (diff)
downloadguix-111110038d3ff78a354f13130994081db82ee0d4.tar.gz
gnu: nghttp2: Remove jemalloc dependency for the Hurd.
* gnu/packages/web.scm (nghttp2)[inputs]: Remove jemalloc for the Hurd.
-rw-r--r--gnu/packages/web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3f59bbdb73..781f76a132 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -41,6 +41,7 @@
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -108,6 +109,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages java)
   #:use-module (gnu packages jemalloc)
   #:use-module (gnu packages image)
@@ -7024,7 +7026,8 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
      ;; Required to build the tools (i.e. without ‘--enable-lib-only’).
      `(("c-ares" ,c-ares)
        ("jansson" ,jansson)             ; for HPACK tools
-       ("jemalloc" ,jemalloc)           ; fight nghttpd{,x} heap fragmentation
+       ,@(if (hurd-target?) '()
+             `(("jemalloc" ,jemalloc))) ; fight nghttpd{,x} heap fragmentation
        ("libev" ,libev)
        ("libxml2" ,libxml2)             ; for ‘nghttp -a’
        ("openssl" ,openssl)))