summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:16 +0200
commit1350f2534d437e2a55de52061ab4b4cae787493e (patch)
tree9b8b707a0faaffbe3005a3b2f64bd9b085ee4a23
parentb8be8977575abfc7efa9cd01507f260b81d9e2a3 (diff)
downloadguix-1350f2534d437e2a55de52061ab4b4cae787493e.tar.gz
gnu: Add texlive-smartunits.
* gnu/packages/tex.scm (texlive-smartunits): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a39978c71..6036386e17 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96026,6 +96026,25 @@ Many commands are provided to serve as a macro programming environment for
 using the extended labels.")
     (license license:lppl)))
 
+(define-public texlive-smartunits
+  (package
+    (name "texlive-smartunits")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/smartunits/"
+                   "tex/latex/smartunits/")
+             (base32
+              "002962fis50p644izb5rj0yx8b54h7jj98ksxrfn5043hxq80za8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/smartunits")
+    (synopsis "Converting between common metric and Imperial units")
+    (description
+     "This LaTeX package implements a @code{\\SmartUnit} macro for converting
+between (some) metric and Imperial units.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar