summary refs log tree commit diff
diff options
context:
space:
mode:
authorJake Leporte <jakeleporte@outlook.com>2023-02-26 18:47:41 -0600
committerLudovic Courtès <ludo@gnu.org>2023-02-27 15:54:10 +0100
commit137390e66cf2e0f835200861376667f24518bdea (patch)
treedbb4e99c7acf2d1cd2c2e6e132aa6c958e08cd21
parent47a14185b1bcf11c4949e3bca95d5136d73e1e40 (diff)
downloadguix-137390e66cf2e0f835200861376667f24518bdea.tar.gz
gnu: Add font-microsoft-cascadia.
* gnu/packages/fonts.scm (font-microsoft-cascadia): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/fonts.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4e7b7d0ac3..13699cdfce 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1266,6 +1266,30 @@ work well in user interface (UI) environments.")
 Sans Pro family.")
     (license license:silofl1.1)))
 
+(define-public font-microsoft-cascadia
+  (package
+    (name "font-microsoft-cascadia")
+    (version "2111.01")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri (string-append
+                    "https://github.com/microsoft/cascadia-code/"
+                    "releases/download/v"
+                    version
+                    "/CascadiaCode-"
+                    version
+                    ".zip"))
+              (sha256
+               (base32
+                "04p72jmbafblrliy5phqi6sqi52wgzpilf3rphppxf7zdlbnizai"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/microsoft/cascadia-code")
+    (synopsis "Monospaced font with programming ligatures")
+    (description
+     "Cascadia is a fun new coding font that comes bundled with Windows
+Terminal, and is now the default font in Visual Studio as well.")
+    (license license:silofl1.1)))
+
 (define-public font-fira-sans
   ;; Fira Sans v4.203 (which corresponds to Fira Mono v3.206) is the final
   ;; version to include UFO sources. It is the same version packaged by other