summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:08:28 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:22:16 +0000
commit13e682ea94d85b4d2dd856231f4e67d47a724141 (patch)
tree5f2051e15e098c5754ed1ef40a1f4c94c0b8f55c
parent35445a7c1a9a788f902594dd7ba0cd3547c7c7e6 (diff)
downloadguix-13e682ea94d85b4d2dd856231f4e67d47a724141.tar.gz
gnu: go-github-com-nsqio-go-diskqueue: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-nsqio-go-diskqueue): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I2051eb1f8a40eeab9c8cc96c540413f5818dd78e
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e6decd2906..e4b6a09f2d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -378,6 +378,29 @@ library which posts the metrics to the Prometheus client registry and just
 updates the registry.")
     (license license:asl2.0)))
 
+(define-public go-github-com-nsqio-go-diskqueue
+  (package
+    (name "go-github-com-nsqio-go-diskqueue")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nsqio/go-diskqueue")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hp66hkmfn0nyf3c53a40f94ah11a9rj01r5zp3jph9p54j8rany"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/nsqio/go-diskqueue"))
+    (home-page "https://github.com/nsqio/go-diskqueue")
+    (synopsis "Go package providing a file system backed FIFO queue")
+    (description
+     "The @code{diskqueue} Go package provides a file system backed FIFO
+queue.")
+    (license license:expat)))
+
 (define-public go-github-com-nsqio-go-nsq
   (package
     (name "go-github-com-nsqio-go-nsq")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d7c7198cc0..d529490b49 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3076,29 +3076,6 @@ web framework
 sunset times from geographical coordinates and a date.")
       (license license:expat))))
 
-(define-public go-github-com-nsqio-go-diskqueue
-  (package
-    (name "go-github-com-nsqio-go-diskqueue")
-    (version "1.1.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/nsqio/go-diskqueue")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1hp66hkmfn0nyf3c53a40f94ah11a9rj01r5zp3jph9p54j8rany"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/nsqio/go-diskqueue"))
-    (home-page "https://github.com/nsqio/go-diskqueue")
-    (synopsis "Go package providing a file system backed FIFO queue")
-    (description
-     "The @code{diskqueue} Go package provides a file system backed FIFO
-queue.")
-    (license license:expat)))
-
 (define-public go-github-com-hebcal-gematriya
   (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
         (revision "0"))