summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-11-20 22:35:41 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-02 08:35:06 -0600
commit1671c07cc713525bd91d5e0a704e01b5d423c0ba (patch)
treefd13ee8bb412f58351d3fe082ee7bfdc86dc8a22
parentc937562e2fd2f27c2adcd2b1c78a43c2587c0efe (diff)
downloadguix-1671c07cc713525bd91d5e0a704e01b5d423c0ba.tar.gz
gnu: Add python-distutils-extra.
* gnu/packages/python.scm (python-distutils-extra, python2-distutils-extra):
  New variables.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0e9d7923ea..d024c1c360 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2230,6 +2230,32 @@ simple and Pythonic domain language.")
 (define-public python2-sqlalchemy
   (package-with-python2 python-sqlalchemy))
 
+(define-public python-distutils-extra
+  (package
+    (name "python-distutils-extra")
+    (version "2.38")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "https://launchpad.net/python-distutils-extra/trunk/"
+                          version "/+download/python-distutils-extra-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0lx15kcbby9zisx33p2h5hgakgwh2bvh0ibag8z0px4j6ifhs41x"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://launchpad.net/python-distutils-extra/")
+    (synopsis "Enhancements to Python's distutils")
+    (description
+     "The python-distutils-extra module enables you to easily integrate
+gettext support, themed icons, and scrollkeeper-based documentation into
+Python's distutils.")
+    (license gpl2)))
+
+(define-public python2-distutils-extra
+  (package-with-python2 python-distutils-extra))
 (define-public python-pillow
   (package
     (name "python-pillow")