summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-06 15:22:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-06 15:22:24 +0200
commit169c658f7f286efae397fa3eda55b1c56fa92a01 (patch)
tree417100302f09cffb645de46276e0753d48be9964
parent3359a70834f80f36ce8ef673f0f8adc1cc66d0d5 (diff)
downloadguix-169c658f7f286efae397fa3eda55b1c56fa92a01.tar.gz
gnu: tar: Skip racy tests.
* gnu/packages/base.scm (tar)[arguments]: Skip two more tests in #:make-flags.
-rw-r--r--gnu/packages/base.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 88eaee767f..1be63c37b2 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -191,7 +191,15 @@ implementation offers several extensions over the standard utility.")
       ;; "a/y: Not linked to a/z" and fails, presumably due to differences in
       ;; the order in which 'diff' traverses directories.  That leads to a
       ;; test failure even though conceptually the test passes.  Skip it.
-      #:make-flags '("TESTSUITEFLAGS=-k '!link mismatch'")))
+      ;; Test 117 and 118 are prone to race conditions too, particularly
+      ;; when cross-compiling, so we skip those as well.  All issues have
+      ;; been fixed upstream in these commits:
+      ;; <https://git.savannah.gnu.org/cgit/tar.git/commit/?id=847a36f>
+      ;; <https://git.savannah.gnu.org/cgit/tar.git/commit/?id=64b43fd>
+      #:make-flags (list (string-append
+                          "TESTSUITEFLAGS= -k '!link mismatch,"
+                          "!directory removed before reading,"
+                          "!explicitly named directory removed before reading'"))))
 
    ;; When cross-compiling, the 'set-shell-file-name' phase needs to be able
    ;; to refer to the target Bash.