summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 22:02:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:33 +0100
commit17263ef5e84029ddaadef3ab40fcba7cbc9d6c43 (patch)
treebcda2526546aaa2b4cd91e17e07ef78242d0cbdc
parent3b5378a87fd067dca07b35163e85056044d61cdf (diff)
downloadguix-17263ef5e84029ddaadef3ab40fcba7cbc9d6c43.tar.gz
gnu: python-pluggy: Update to 0.13.1.
* gnu/packages/python-xyz.scm (python-pluggy): Update to 0.13.1.
[properties]: New field.
(python2-pluggy): Stay on 0.11.0.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ae650c7cc..9f37da99d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8751,14 +8751,14 @@ library as well as on the command line.")
 (define-public python-pluggy
   (package
    (name "python-pluggy")
-   (version "0.11.0")
+   (version "0.13.1")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "pluggy" version))
      (sha256
       (base32
-       "10511a54dvafw1jrk75mrhml53c7b7w4yaw7241696lc2hfvr895"))))
+       "1c35qyhvy27q9ih9n899f3h4sdnpgq027dbiilly2qb5cvgarchm"))))
    (build-system python-build-system)
    (native-inputs
     `(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -8766,10 +8766,21 @@ library as well as on the command line.")
    (description "Pluggy is an extraction of the plugin manager as used by
 Pytest but stripped of Pytest specific details.")
    (home-page "https://pypi.python.org/pypi/pluggy")
+   (properties `((python2-variant . ,(delay python2-pluggy))))
    (license license:expat)))
 
 (define-public python2-pluggy
-  (package-with-python2 python-pluggy))
+  (let ((base (package-with-python2 (strip-python2-variant
+                                     python-pluggy))))
+    (package/inherit
+     base
+     (version "0.11.0")
+     (source (origin
+               (method url-fetch)
+               (uri (pypi-uri "pluggy" version))
+               (sha256
+                (base32
+                 "10511a54dvafw1jrk75mrhml53c7b7w4yaw7241696lc2hfvr895")))))))
 
 (define-public python-tox
   (package