summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:51 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:15 -0500
commit1754f847aa854d004348a6d1090b0132ad87055a (patch)
treec64ab2af65fba09a2aa6ae393993fe3c64386cf9
parent2a0b7df5b4b9e7b27a79e7ecc646113af97808b1 (diff)
downloadguix-1754f847aa854d004348a6d1090b0132ad87055a.tar.gz
gnu: go-github-com-gorilla-securecookie: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-securecookie): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

Change-Id: Iae8beed5e7a099033585bcab33cd42d237d2746d
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c0ceb5b7ce..1a77e0f6f2 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -212,6 +212,30 @@ web applications.")
 incoming requests with their respective handler.")
     (license license:bsd-3)))
 
+(define-public go-github-com-gorilla-securecookie
+  (package
+    (name "go-github-com-gorilla-securecookie")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gorilla/securecookie")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16bqimpxs9vj5n59vm04y04v665l7jh0sddxn787pfafyxcmh410"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gorilla/securecookie"))
+    (home-page "https://github.com/gorilla/securecookie")
+    (synopsis "Encodes and decodes authenticated and optionally encrypted
+cookie values")
+    (description
+     "Gorilla/securecookie encodes and decodes authenticated and optionally
+encrypted cookie values for Go web applications.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-gorilla-websocket
   (package
     (name "go-github-com-gorilla-websocket")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 841b507cda..53ae15e2e2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4867,31 +4867,6 @@ the @code{c2go} tool at
 @url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
     (license license:expat)))
 
-(define-public go-github-com-gorilla-securecookie
-  (package
-    (name "go-github-com-gorilla-securecookie")
-    (version "1.1.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/gorilla/securecookie")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "16bqimpxs9vj5n59vm04y04v665l7jh0sddxn787pfafyxcmh410"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/gorilla/securecookie"))
-    (home-page "https://github.com/gorilla/securecookie")
-    (synopsis "Encodes and decodes authenticated and optionally encrypted
-cookie values")
-    (description
-     "Gorilla/securecookie encodes and decodes authenticated and optionally
-encrypted cookie values for Go web applications.")
-    (license license:bsd-3)))
-
 (define-public go-github-com-gorilla-sessions
   (package
     (name "go-github-com-gorilla-sessions")