summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:22 +0200
commit176b8d448de02cc2593f60bcfa49ac67ca06f611 (patch)
tree01f6202eaef26ecda382397b0617c8505d7723f1
parent090b0051cb3be48465f525a97790f2cde43ddae9 (diff)
downloadguix-176b8d448de02cc2593f60bcfa49ac67ca06f611.tar.gz
gnu: Add texlive-proofread.
* gnu/packages/tex.scm (texlive-proofread): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8cf63c267f..006c08d9d8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93073,6 +93073,30 @@ of customizations are possible, allowing you to create an unique progress bar
 on your own.  The package uses TikZ to produce its graphics.")
     (license license:lppl)))
 
+(define-public texlive-proofread
+  (package
+    (name "texlive-proofread")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/proofread/"
+                   "source/latex/proofread/"
+                   "tex/latex/proofread/")
+             (base32
+              "13sp7xd1a5k25l5wvjzk51p01zk6wcnj5fjd7fpca4indqz3x2kx")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/proofread")
+    (synopsis "Commands for inserting annotations")
+    (description
+     "This package defines a few LaTeX commands that may be useful when you
+proofread a LaTeX document.  They allow you to easily highlight text and add
+comments in the margin.  Vim escape sequences are provided for inserting or
+removing these LaTeX commands in the source.  Options are provided for
+displaying the document with extra line spacing, and for displaying it in
+either corrected or uncorrected state, both without margin notes.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar