summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 13:40:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:56 +0200
commit179900942d3ad6f26947c570421a71b8666124db (patch)
tree1fb5279ad1a4cedfcb94ed9c84d9a951521e3019
parentf540aa0e76b124b4658f6d33222f031ca5c528d6 (diff)
downloadguix-179900942d3ad6f26947c570421a71b8666124db.tar.gz
gnu: rust-botan: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-botan-0.10, rust-botan-0.8,
rust-botan-sys-0.10, rust-botan-sys-0.8, rust-botan-src-0.21903,
rust-botan-src-0.21703): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register new file.

Change-Id: I459c94e9f70a51bdf48020792562e57ebc2119df
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crates-crypto.scm146
-rw-r--r--gnu/packages/crates-io.scm115
-rw-r--r--gnu/packages/sequoia.scm1
4 files changed, 149 insertions, 114 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0668ad34dc..917ff9db97 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -202,6 +202,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/cppi.scm				\
   %D%/packages/cran.scm				\
   %D%/packages/crates-apple.scm		\
+  %D%/packages/crates-crypto.scm		\
   %D%/packages/crates-io.scm			\
   %D%/packages/crates-graphics.scm		\
   %D%/packages/crates-gtk.scm			\
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
new file mode 100644
index 0000000000..67de332f12
--- /dev/null
+++ b/gnu/packages/crates-crypto.scm
@@ -0,0 +1,146 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages crates-crypto)
+  #:use-module (guix build-system cargo)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages crates-io)
+  #:use-module (gnu packages crypto))
+
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+
+(define-public rust-botan-0.10
+  (package
+    (name "rust-botan")
+    (version "0.10.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1vzl5pdysh848zpphsgvj9c40zdi3ynl32zzixsd8vg4vaflhb49"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-botan-sys" ,rust-botan-sys-0.10))
+       #:cargo-development-inputs
+       (("rust-hex" ,rust-hex-0.4)
+        ("rust-wycheproof" ,rust-wycheproof-0.5))))
+    (inputs (list botan))
+    (home-page "https://botan.randombit.net/")
+    (synopsis "Rust wrapper for Botan cryptography library")
+    (description "Rust wrapper for Botan cryptography library")
+    (license license:expat)))
+
+(define-public rust-botan-0.8
+  (package
+    (inherit rust-botan-0.10)
+    (name "rust-botan")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "08bmiyn7c3b0dgx20w6hr28d9jcq7cj78cchr84pc686sb2s41ik"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-botan-sys" ,rust-botan-sys-0.8)
+        ("rust-cstr-core" ,rust-cstr-core-0.2)
+        ("rust-cty" ,rust-cty-0.2))))))
+
+(define-public rust-botan-sys-0.10
+  (package
+    (name "rust-botan-sys")
+    (version "0.10.3")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan-sys" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1cbjr44gc5dhmgl43sfiqzbsma4anfi3h26m4yzsli23yd1lmyf8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-botan-src" ,rust-botan-src-0.21903))))
+    (inputs (list botan))
+    (home-page "https://botan.randombit.net/")
+    (synopsis "FFI wrapper for Botan cryptography library")
+    (description "FFI wrapper for Botan cryptography library")
+    (license license:expat)))
+
+(define-public rust-botan-sys-0.8
+  (package
+    (inherit rust-botan-sys-0.10)
+    (name "rust-botan-sys")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan-sys" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "1m11zblxfanrhl97j7z3ap7n17rr8j0rg91sr7f9j6y2bsniaz1x"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-botan-src" ,rust-botan-src-0.21703)
+        ("rust-cty" ,rust-cty-0.2))))))
+
+(define-public rust-botan-src-0.21903
+  (package
+    (name "rust-botan-src")
+    (version "0.21903.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan-src" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19fhll4g0v8hbyjxg8c790l9ln5xgf4r6xdcnw438mpy81hvrdxy"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin (delete-file-recursively "botan")))))
+    (build-system cargo-build-system)
+    (arguments '(#:skip-build? #t))
+    (home-page "https://botan.randombit.net/")
+    (synopsis "Sources of Botan cryptography library")
+    (description "Sources of Botan cryptography library")
+    (license license:expat)))
+
+(define-public rust-botan-src-0.21703
+  (package
+    (inherit rust-botan-src-0.21903)
+    (name "rust-botan-src")
+    (version "0.21703.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "botan-src" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0s2ad9q84qsrllfsbj7hjhn7gr3hab9ng6lwzwqmimia6yvja8y8"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin (delete-file-recursively "botan")))))))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b964333984..712341a101 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -75,6 +75,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-apple)
+  #:use-module (gnu packages crates-crypto)
   #:use-module (gnu packages crates-graphics)
   #:use-module (gnu packages crates-gtk)
   #:use-module (gnu packages crates-tls)
@@ -8103,120 +8104,6 @@ comes with a strict specification.")
     (description "This crate implements schema generator for @code{borsh}.")
     (license license:asl2.0)))
 
-(define-public rust-botan-0.10
-  (package
-    (name "rust-botan")
-    (version "0.10.3")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1vzl5pdysh848zpphsgvj9c40zdi3ynl32zzixsd8vg4vaflhb49"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-botan-sys" ,rust-botan-sys-0.10))
-       #:cargo-development-inputs
-       (("rust-hex" ,rust-hex-0.4)
-        ("rust-wycheproof" ,rust-wycheproof-0.5))))
-    (inputs (list botan))
-    (home-page "https://botan.randombit.net/")
-    (synopsis "Rust wrapper for Botan cryptography library")
-    (description "Rust wrapper for Botan cryptography library")
-    (license license:expat)))
-
-(define-public rust-botan-0.8
-  (package
-    (inherit rust-botan-0.10)
-    (name "rust-botan")
-    (version "0.8.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "08bmiyn7c3b0dgx20w6hr28d9jcq7cj78cchr84pc686sb2s41ik"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-botan-sys" ,rust-botan-sys-0.8)
-        ("rust-cstr-core" ,rust-cstr-core-0.2)
-        ("rust-cty" ,rust-cty-0.2))))))
-
-(define-public rust-botan-sys-0.10
-  (package
-    (name "rust-botan-sys")
-    (version "0.10.3")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan-sys" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1cbjr44gc5dhmgl43sfiqzbsma4anfi3h26m4yzsli23yd1lmyf8"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-botan-src" ,rust-botan-src-0.21903))))
-    (inputs (list botan))
-    (home-page "https://botan.randombit.net/")
-    (synopsis "FFI wrapper for Botan cryptography library")
-    (description "FFI wrapper for Botan cryptography library")
-    (license license:expat)))
-
-(define-public rust-botan-sys-0.8
-  (package
-    (inherit rust-botan-sys-0.10)
-    (name "rust-botan-sys")
-    (version "0.8.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan-sys" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "1m11zblxfanrhl97j7z3ap7n17rr8j0rg91sr7f9j6y2bsniaz1x"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-botan-src" ,rust-botan-src-0.21703)
-        ("rust-cty" ,rust-cty-0.2))))))
-
-(define-public rust-botan-src-0.21903
-  (package
-    (name "rust-botan-src")
-    (version "0.21903.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan-src" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "19fhll4g0v8hbyjxg8c790l9ln5xgf4r6xdcnw438mpy81hvrdxy"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin (delete-file-recursively "botan")))))
-    (build-system cargo-build-system)
-    (arguments '(#:skip-build? #t))
-    (home-page "https://botan.randombit.net/")
-    (synopsis "Sources of Botan cryptography library")
-    (description "Sources of Botan cryptography library")
-    (license license:expat)))
-
-(define-public rust-botan-src-0.21703
-  (package
-    (inherit rust-botan-src-0.21903)
-    (name "rust-botan-src")
-    (version "0.21703.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "botan-src" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0s2ad9q84qsrllfsbj7hjhn7gr3hab9ng6lwzwqmimia6yvja8y8"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin (delete-file-recursively "botan")))))))
-
 (define-public rust-boxfnonce-0.1
   (package
     (name "rust-boxfnonce")
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 0501bdaf15..067197ffc5 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -27,6 +27,7 @@
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)  ; glibc
+  #:use-module (gnu packages crates-crypto)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages crates-tls)
   #:use-module (gnu packages crates-web)