summary refs log tree commit diff
diff options
context:
space:
mode:
authorEthan R. Jones <doubleplusgood23@gmail.com>2017-05-27 11:19:22 -0400
committerLudovic Courtès <ludo@gnu.org>2017-05-31 17:08:45 +0200
commit17ce0d45bdf6089c78d90755d90589894275634f (patch)
tree98ef9bbd9451514eb9eb2bb1242a9d85aa7f0ba0
parent3e894917414239cab1737d89feb263e0825ae7c5 (diff)
downloadguix-17ce0d45bdf6089c78d90755d90589894275634f.tar.gz
gnu: Add libzen.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add new file.
* gnu/packages/cpp.scm (libzen): New varible.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cpp.scm59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4ad478d5dd..549aaf1abb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -95,6 +95,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/connman.scm			\
   %D%/packages/cook.scm				\
   %D%/packages/cpio.scm				\
+  %D%/packages/cpp.scm 				\
   %D%/packages/cppi.scm				\
   %D%/packages/cross-base.scm			\
   %D%/packages/crypto.scm			\
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
new file mode 100644
index 0000000000..da192553a5
--- /dev/null
+++ b/gnu/packages/cpp.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cpp)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages autotools))
+
+(define-public libzen
+  (package
+    (name "libzen")
+    (version "0.4.35")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://mediaarea.net/download/source/"
+                                  name "/" version "/"
+                                  name "_" version ".tar.bz2"))
+              (sha256
+               (base32
+                "12a1icgcffgv503ii2k1453kxg5hfly09mf4zjcc80aq8a6rf8by"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       ;; build scripts not in root of archive
+       (modify-phases %standard-phases
+         (add-before 'configure 'pre-configure
+           (lambda _
+             (chdir "Project/GNU/Library")))
+         (add-before 'configure 'autogen
+           (lambda _
+             (zero? (system* "./autogen.sh")))))))
+    (home-page "https://github.com/MediaArea/ZenLib")
+    (synopsis "C++ utility library")
+    (description "ZenLib is a C++ utility library.  It includes classes for handling
+strings, configuration, bit streams, threading, translation, and cross-platform
+operating system functions.")
+    (license license:zlib)))