summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-12 00:41:38 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-10 02:36:35 +0200
commit1898eaa3357124034fecfbeb157b39b0f4e8c0c0 (patch)
tree942b2030f89d80f124c116947738a9017437c29d
parentab28aa229bff7af49ee9a413366000dd61755878 (diff)
downloadguix-1898eaa3357124034fecfbeb157b39b0f4e8c0c0.tar.gz
gnu: Add python-traceback2.
* gnu/packages/python.scm (python-traceback2, python2-traceback2): New
  variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 395e39911c..fd08f1a469 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16532,3 +16532,34 @@ lines are read from a single file.")
 
 (define-public python2-linecache2
   (package-with-python2 python-linecache2))
+
+(define-public python-traceback2
+  (package
+    (name "python-traceback2")
+    (version "1.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "traceback2" version))
+        (sha256
+          (base32
+            "0c1h3jas1jp1fdbn9z2mrgn3jj0hw1x3yhnkxp7jw34q15xcdb05"))))
+    (build-system python-build-system)
+    (arguments
+     `(;; python-traceback2 and python-unittest2 depend on one another.
+       #:tests? #f))
+    (native-inputs
+     `(("python-pbr" ,python-pbr)))
+    (propagated-inputs
+      `(("python-linecache2" ,python-linecache2)))
+    (home-page
+      "https://github.com/testing-cabal/traceback2")
+    (synopsis "Backports of the traceback module")
+    (description
+      "This module provides a standard interface to extract, format and print
+stack traces of Python programs.  It exactly mimics the behavior of the Python
+interpreter when it prints a stack trace.")
+    (license license:psfl)))
+
+(define-public python2-traceback2
+  (package-with-python2 python-traceback2))